관리 메뉴

키스세븐

out of memory at line에러 - jquery일 경우의 해결방안 본문

홈피와 블로그

out of memory at line에러 - jquery일 경우의 해결방안

키스 키스세븐 2015. 1. 11. 02:00
공유하기 링크
필요하면 공유하세요 ^^
이 블로그를 북마크 하세요! 좋은 정보가 계속 이어집니다.

[out of memory at line에러 - jquery일 경우의 해결방안] 





이 방법은 jquery를 이용하여 사이트를 제작하는 경우에 해당하는 에러 해결방안입니다.


슬라이딩 메뉴나 갤러리 등의 제작을 하기 위해 jquery를 사용하는 경우가 많습니다.

그런데 이 jquery는 jquery-1.x.x.min.js같은 스크립트파일을 호출해서 사용합니다.



 


 



문제의 원인


문제는 이 파일들이 호환이 안 되서!

예를들면 1.5.5와 1.5.4도 1.5.6도 서로 호환이 안 돼고 오로지 jquery-1.5.5.min.js파일을 호출해야만 한다는 것입니다.


  


 


해결의 난점


그러나 이 에러는 문제가 생겨도 jquery 때문이라고 정확히 메세지를 주지 않고 엉뚱하게 "out of memory at line"같은 메모리 에러를 띄운다는 것에 있습니다.

결국 초보자의 경우 에러의 문제를 찾을 수 없게 되는 것이죠.


 


 


 


해결 방안


예를들어 out of memory at line 18이라는 에러가 났다면 그 에러부분을 찾으려고 하지 말고 FTP로 자신의 계정에 들어가서 사용하려는 파일소스의 jquery의 버전을 확인하길 바랍니다.


jquery-1.x.x.min.js 처럼 파일이 존재하는지, 사용하는 코드에 적힌 소스의 jquery-1.x.x.min.js부분과 버전이 같은지를 확인해야 합니다.

맞지 않다면 검색을 통하여 자신과 맞는 .js파일을 다운 받아야 합니다.


 


 


도움말


만약, 그누보드나 제로보드XE, 이지보드, 테크보드 등 보드 프로그램을 사용하는 경우엔 보드의 부속파일을 잘 살펴보면 찾을 수 있을 것입니다.

이 것을 사용하는 .php 등이 있는 폴더에 복사해서 교체하세요.

[저작권법 표시] 이 글의 원본: 키스세븐(www.kiss7.kr)

 


만약, 두개를 동시에 사용하기 때문에 이런 에러가 난다면 상위버전의 파일로 모두 교체한 다음에 .php 등의 소스를 열어서 교체한 상위 버전으로 변경해서 저장하면 됩니다.

기본적으로는 하나의 계정에서는 하나의 jquery-1.x.x.min.js 버전을 이용하는 것이 좋습니다.


★ 이 정보가 도움이 된다면 아래의 공감을 부탁드립니다! ^^.
(로그인 필요없음)


키스세븐지식은 키스세븐과 그룹 사이트입니다.

아래로 더 내려 가 보세요!

혹시 읽을만한 것이 또 있을지도 모르잖아요? ^^

이 블로그를 북마크 하세요! 좋은 정보가 계속 이어집니다.
http://kiss7.tistory.com

0 Comments
댓글쓰기 폼